Suppport ipv6 checks
I would like to check a self hosted server, that only has a public ipv6 address.
Currently manually entering the resolved ipv6 address gives me an error:
RequestError: Error: connect EAFNOSUPPORT
ipv6Adress:443 - Local (undefined:undefined)It would be nice if ipv6 would have some kind of support.
I imagine that just automatically supporting it / falling back to it might lead to confusion, so ideally checks would be made to both ipv4 and ipv6 separately and there is some setting to enable / disable ipv6 to avoid confusion.
Log in to comment and vote
Comments8
Stefan Lobbenmeier
Aug 24, 2023
There was one caveat, which is that unlike the browser it did not use ipv6 automatically, I had to remove the ipv4 entry (which was wrong) from my DNS server, now that my DNS server only returns an IPv6 address the check is running smoothly.
Nothing I expect to be fixed, but just something to keep in mind if someone else runs into that particular issue
Stefan Lobbenmeier
Aug 24, 2023
I can confirm that this is now working in my account ❤️ great job!
Tim Nolet
Aug 24, 2023
We just rolled out IPv6 support. Have a look at the changelog entry right here: https://feedback.checklyhq.com/changelog/64e763f5072324e1717ad732
Tim Nolet
Aug 18, 2023
We've started rollout of Ipv6 by enabling it in parts of our stack. This rollout is staged so not all users will have it enabled right away. We will update here again once the rollout has been completed.
Vito Sabella
Aug 9, 2023
I want to add support for this. We want to use synthetics to target 100% ipv6-only services and ensure they are running and its a critical use case for our synthetics.
Tim Nolet
Jul 27, 2023
Thanks Stefan, I will check your account. We are reshuffling our infra away from Lambda and this is one of the use cases that would open up. It does not seem to work yet so we will have a look what we need to do to support this.
Tim Nolet
Jul 27, 2023
Hi Stefan, sorry for the late reply. Are you referencing browser or API checks here. And could you give me the URL to the ipv6 resource if not private?
Stefan Lobbenmeier
Jul 27, 2023
Hi Tim - both did not work in my testing. Feel free to check on my account for the URL, I would rather not share it on a public forum.
But I have since learned that it seems to be caused by the AWS lamda runtime, which you can host Lamdas on an ipv6 address, they cannot call other ipv6 endpoints.
I will probably end up having a load balancer hosted somewhere that allows ipv4 requests and forwards them to my server